System Requirements (Updated January 2020)

Please see important information at the bottom of this page regarding discontinued support for Internet Explorer in later versions of [email protected] Software.

This article details the different Operating Systems and other Technology Requirements for different versions of [email protected] Software used in conjunction with Infor SunSystems, Microsoft Dynamics 365, Microsoft Business Central, SAP, Sage and Coda.

Versions are shown in order of release and therefore the latest version of our software is shown at the bottom of this article.

Please also review the Components Page for information on additional components that need to be installed.

Version 2.5.X

o SQL 2000 or 2005
o Server Operating System – Windows 2000 or 2003
o Client Operating System – Windows 2000 or XP
o Browser Version – IE 5, 6 or 7
o .NET Version 1.1
o IIS Version 5, 6

Version 3.0.X

o SQL 2000 or 2005
o Server Operating System – Windows 2000 or 2003
o Client Operating System – Windows XP or Vista
o Browser Version – IE 6 or 7
o .NET Version 2 or above
o IIS Version 6, 7

Version 3.1.X

o SQL 2000 or 2005
o Server Operating System – Windows 2003
o Client Operating System – Windows XP or Vista
o Browser Version – IE 7
o .NET Version 2 or above
o IIS Version 6, 7

Version 3.2.X

o SQL 2000 or 2005
o Server Operating System – Windows 2003
o Client Operating System – Windows XP or Vista
o Browser Version – IE 7 or 8
o NET Version 2 or above
o IIS Version 6, 7

Version 3.3.X

o SQL 2005 or 2008
o Server Operating System – Windows 2003 or 2008
o Client Operating System – Windows XP or Vista or Windows 7
o Browser Version – IE 7 or 8, Firefox
o .NET Version 3.5
o IIS Version 6, 7

Version 4.0.X

o SQL 2005 or 2008
o Server Operating System – Windows 2003 or 2008
o Client Operating System – Windows XP or Vista or Windows 7
o Browser Version – IE 7 or 8, Firefox
o .NET Version 3.5 SP1
o IIS Version 6, 7
o MS Office 2003 and higher,

(Note: MS Office 2010 requires the ActiveX Control Pad Component to be installed separately – Earlier versions of MS Office installed the component automatically)

Version 4.6

o SQL 2008 or 2008R2
o Server Operating System – Windows 2008, 2008R2 (With the latest patches)
o Client Operating System – Windows Vista or Windows 7
o Browser Version – IE 8, IE 9, Firefox, Safari
o .NET Version 4
o IIS Version 7

Version 4.7

o SQL 2008 or 2008R2 or 2012
o Server Operating System – Windows 2008, 2008R2 (With the latest patches) or Windows 2012
o Client Operating System – Windows Vista or Windows 7 or Windows 8
o Browser Version – IE 8, IE 9, IE10, Firefox, Safari and Chrome
o .NET Version 4
o MS Exchange 2007 SP1, 2010
o IIS Version 7
o Crystal Runtime Version 13.0.2

Version 4.8

o SQL 2008 or 2008R2 or 2012
o Server Operating System – Windows 2008, 2008R2 (With the latest patches) or Windows 2012
o Client Operating System – Windows 7 or Windows 8
o Browser Version – IE 9, IE10 and IE11. Firefox 20, Safari 6 and 7 and Chrome
o .NET Version 4.5 (Appropriate 32bit or 64bit version
o MS Exchange 2007 SP1, 2010, 2013
o IIS Version 7
o Crystal Runtime Version 13.0.5

Version 5.0

o SQL 2008 or 2008R2 or 2012 or 2014
o Server Operating System – Windows 2008, 2008R2 (With the latest patches) or Windows 2012
o Client Operating System – Windows 7 or Windows 8 or Windows 10
o Browser Version – IE10 and IE11. Firefox 30, Safari 6 and 7 and Chrome (Please note that IE 9 and below are no longer supported)
o .NET Version 4.5 (Appropriate 32 bit or 64 bit version)
o MS Exchange 2007 SP1, 2010, 2013
o IIS Version 7
o Crystal Runtime Version 13.0.8
o Microsoft Office 32 bit on machines running Maintenance and/or Task Scheduler. (A Microsoft Runtime may be installed as an alternative).
o Microsoft Office 64 bit on machines accessing via Browser. (A Microsoft Runtime may be installed as an alternative).

Version 6.0

o SQL 2008R2 or 2012 or 2014 or 2016
o Server Operating System – Windows Server 2008R2, Windows Server 2012, Windows Server 2012 R2, Windows Server 2016
o Client Operating System – Windows 7 or Windows 8.1 or Windows 10
o Browser Version – IE11, Edge, Firefox 50+, Safari 10.3+ and Chrome 60+
o .NET Version 4.6.2 (Appropriate 32 bit or 64 bit version)
o MS Exchange 2010, 2013, 2016
o IIS Version 7
o Crystal Runtime Version 13.0.17
o Microsoft Office 32 bit on machines running Maintenance and/or Task Scheduler. (A Microsoft Runtime may be installed as an alternative).
o Microsoft Office 64 bit on machines accessing via Browser. (A Microsoft Runtime may be installed as an alternative).

Version 6.1

o SQL 2008R2 or 2012 or 2014 or 2016 or 2017
o Server Operating System – Windows Server 2008R2, Windows Server 2012, Windows Server 2012 R2, Windows Server 2016
o Client Operating System – Windows 7 or Windows 8.1 or Windows 10
o Browser Version – IE11, Edge, Firefox 50+, Safari 10.3+ and Chrome 60+
o .NET Version 4.6.2 or later (Appropriate 32 bit or 64 bit version)
o MS Exchange 2010, 2013, 2016
o IIS Version 7
o Crystal Runtime Version 13.0.18 or later
o Microsoft Office 32 bit on machines running Maintenance and/or Task Scheduler. (A Microsoft Runtime may be installed as an alternative).
o Microsoft Office 64 bit on machines accessing via Browser. (A Microsoft Runtime may be installed as an alternative).

Version 6.2

o SQL 2012 or 2014 or 2016 or 2017
o Server Operating System – Windows Server 2012, Windows Server 2012 R2, Windows Server 2016
o Client Operating System – Windows 8.1 or Windows 10
o Browser Version – Edge, Firefox 50+, Safari 10.3+ and Chrome 60+ Please Note: Internet Explorer is not Longer Supported (See Below)
o .NET Version 4.7 or later (Appropriate 32 bit or 64 bit version)
o MS Exchange 2010, 2013, 2016
o Crystal Runtime Version 13.0.18 or later
o Microsoft Office 32 bit on machines running Maintenance and/or Task Scheduler. (A Microsoft Runtime may be installed as an alternative).
o Microsoft Office 64 bit on machines accessing via Browser. (A Microsoft Runtime may be installed as an alternative).

Please note that the [email protected] and [email protected] Maintenance Applications are not supported in a WAN environment. For clients who are deploying this architecture we recommend the use of Citrix or Remote Desktop / Terminal Server.

Please also review the Components Page for information on additional components that need to be installed.

Installation Quick Guide

The following notes are intended as a quick guide checklist for consultants and are not intended to replace the installation guide. Installations should only be carried out by a qualified [email protected] authorised Installation Technician.

1.       Install CRRuntime_32bit_13_0_17

2.       Install SQLSysClrTypes

3.       Install ReportViewer2012Redist

4.       Install [email protected]_XXX or [email protected]_XXX or [email protected]_XXX – (choose only maintenance component unless installing on a server)

5.       If applicable copy preconfigured TAWDb.cfg file into C:\Program Files (x86)\[email protected]\[email protected]\[email protected] Maintenance or C:\Program Files (x86)\[email protected]\[email protected]\[email protected] Maintenance or C:\Program Files (x86)\[email protected]\[email protected]\[email protected] Maintenance

6.       Login using supplied username and password

7.       If maintenance does not start then this means you are missing a key component (typically installed via Microsoft Office) and you should install setuppad.exe in “XP SP3 Compatibility mode” also.

Support for Internet Explorer 11

With the release of Version 6.2 of [email protected] Software ([email protected], [email protected] and [email protected]) in October 2019 we have discontinued support for IE 11 (and all previous Internet Explorer Versions) and going forward our supported browsers will be:

  • Microsoft Edge (Including the new Chromium edition)
  • Google Chrome
  • Firefox
  • Safari

Clients planning to implement or upgrade to version 6.2 should ensure that they are utilising the latest versions of these browsers. If IE11 is the only approved browser within an organisation then Version 6.1 of [email protected] software is the latest version that can be deployed.

However because of the significant functional and performance improvements in Version 6.2 of our software we would strongly recommend that this latest version or higher is deployed and used with the above browsers (please see above for the latest supported browsers for your version).

Background To Discontinued Support Of IE11

In 2016, Microsoft announced that they were discontinuing development of IE11 and would limit updates to security patches only. This will remain in place for the remaining lifecycle of the Windows versions on which IE 11 is currently available.

As a result of this decision many of the new HTML and Javascript features available to software developers will not work on IE 11.

As a Software Author we are committed to ongoing investment in the development of new and enhanced functionality for our solutions. As such we cannot deploy the latest versions of our software with support for legacy browsers which lack modern HTML and Javascript features.

It is worth noting that as at December 2019 only 3.5% of users were utilising IE (across all versions) and this is in large part due to the enhanced functionality available in Edge, Chrome, Safari and Firefox.

Further Reading

https://support.microsoft.com/en-gb/help/17454/lifecycle-faq-internet-explorer

https://techcommunity.microsoft.com/t5/windows-it-pro-blog/the-perils-of-using-internet-explorer-as-your-default-browser/ba-p/331732

https://www.zdnet.com/article/microsoft-security-chief-ie-is-not-a-browser-so-stop-using-it-as-your-default/

http://kangax.github.io/compat-table/es2016plus/